Friday, 9 January 2015

Problems with VirginMedia Managed Internet Services access

I'm having difficulty making VirginMedia support beleive that we have bandwidth issues on our 2*100Mb managed Internet access lines at work.

I've setup the command line script from https://github.com/sivel/speedtest-cli as detailed in this post:
http://blog.thefoleyhouse.co.uk/2015/01/sivelspeedtest-cli-github.html

user@host:~$ mkdir speedtest-cli
user@host:~$ cd speedtest-cli/
admin@host:~/speedtest-cli$ wget -O speedtest-cli https://raw.github.com/sivel/speedtest-cli/master/speedtest_cli.py --2015-01-09 08:57:52-- https://raw.github.com/sivel/speedtest-cli/master/speedtest_cli.py
Resolving raw.github.com (raw.github.com)... 23.235.43.133
Connecting to raw.github.com (raw.github.com)|23.235.43.133|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently Location: https://raw.githubusercontent.com/sivel/speedtest-cli/master/speedtest_cli.py [following]
--2015-01-09 08:57:53-- https://raw.githubusercontent.com/sivel/speedtest-cli/master/speedtest_cli.py
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 23.235.43.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|23.235.43.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 21791 (21K) [text/plain]
Saving to: `speedtest-cli'
100%[===========================================================================================================================================================>] 21,791 --.-K/s in 0.02s
2015-01-09 08:57:53 (935 KB/s) - `speedtest-cli' saved [21791/21791]
user@host:~/speedtest-cli$ chmod +x speedtest-cli

Here is my result for Site1:
user@site1:~/speedtest-cli$ ./speedtest-cli
Retrieving speedtest.net server list...
Testing from Virgin Media (x.x.x.x)...
Selecting best server based on latency...
Hosted by Virgin Media (Luton) [53.67 km]: 19.772 ms
Testing download speed........................................
Download: 48.70 Mbits/s
Testing upload speed..................................................
Upload: 11.08 Mbits/s

Here is my result for Site2:
user@site2:~/speedtest-cli$ ./speedtest-cli
Retrieving speedtest.net configuration...
Retrieving speedtest.net server list...
Testing from Virgin Media (x.x.x.x)...
Selecting best server based on latency...
Hosted by Virgin Media (Luton) [52.13 km]: 21.677 ms
Testing download speed........................................
Download: 34.93 Mbits/s
Testing upload speed..................................................
Upload: 10.11 Mbits/s

Here is my result from home:
me@home:~/speedtest-cli$ ./speedtest-cli
Retrieving speedtest.net configuration...
Retrieving speedtest.net server list...
Testing from Virgin Media (x.x.x.x)...
Selecting best server based on latency...
Hosted by Fluidata (Hemel Hempstead) [86.39 km]: 22.999 ms
Testing download speed........................................
Download: 152.29 Mbits/s
Testing upload speed..................................................
Upload: 11.65 Mbits/s

Here is my result from home if I force the same test server as work:
karl@littlechef:~/speedtest_cli$ ./speedtest-cli --server 3697
Retrieving speedtest.net server list...
Testing from Virgin Media (x.x.x.x)...
Hosted by Virgin Media (Luton) [109.86 km]: 24.878 ms
Testing download speed........................................
Download: 145.03 Mbits/s
Testing upload speed..................................................
Upload: 11.88 Mbits/s

No comments:

Post a comment